Gmsh incompatibility with OS

I tried to import my .geo file to the SPIS environment and there is an error mentioning the gmsh 2.7 incompatibility with the system’s OS. But the gmsh version in SPIS is 2.8.5. When I tried to generate the geo file through the gmsh in the SPIS environment, I got an error locating the gmsh-options file. But Even though I updated the gmsh version to 4.10.2 and did all the procedures mentioned in the documentation, the error of gmsh 2.7 incompatibility with OS remains. But surprisingly, I’m able to generate a mesh with the pre-existing geo files in SPIS. Can anyone resolve this issue?

The error message mentionning “Gmsh 2.7” is a badly written message, you should interpret it as the following “There was an error meshing the geometry with the embedded Gmsh version”.

In your case, I think your geo file is in the “Gmsh 4” file format, not compatible with the embedded version of Gmsh: it as different commands.
If you cannot make easily your file compatible with Gmsh 2 format version, one option is to mesh your geo file with an external version of Gmsh 4.

When you save the obtained mesh to .msh file format, please be careful to select the correct mesh file version for SPIS.

To do so:

  • Select File > Export
  • In Format select Mesh - Gmsh MSH (*.msh), type the filename and click on Ok
  • In the MSH Options pop-up, in Format select Version 2 - ASCII and click Ok

You can then import the obtained mesh file into SPIS (by selecting Skip geometry editor in the project creation panel.

Another option ias to include this command on the .geo file: