[Archive] UnsupportedClassVersionError: Bad version number in .class file

Message by Clucas Simon:
I rebuilt spis.jar in my eclipse editor and subsequently get this error when i run spis with the new jar file. In understand why I get the error, I asume somwhere, a JVM is trying to execute a java class that has been built with a later compiler, but I cant seem to fix it.
I have pointed eclipse to my jdk5 distribution, which I think the nuild.xml file should also pick up and use (or does it) and I have set the same jvm/jdk in the jython scripts.
But still get the error. I have cleaned the project and recompiles, and also deleted all the jython java classes.
Any ideas?

Message by Clucas Simon:
Sorry but I think I have sorted this problem.Although I was specifying the compliance within the eclipse framework, when I ran the ant script it was using the compiled class files within its build directory which is different from where the eclipse compile process puts class files, hence the eclipse clean operation would not help. Deleting the build directory forces the ant script to recompile and and make the jar file.