[Archive] Trouble with SPIS 4 on Mac

Message by __ Landon Spear__:
Hello all,
I’m attempting to get SPIS_4_0_00_OSX up and running on a new iMac. I haven’t been able to get any simulation to finish yet and I was hoping maybe someone might be able to help. When I run the simulation internally it begins executing but I run out of memory after ~20min. Even after adjusting the -Xmx flag in the jython.bat file to higher values, I still can’t seem to finish any internal simulation without the java heap error. When I attempt to run the simulation externally on the OS daemon I immediately get the following error:
Exception in thread “AWT-EventQueue-0” Traceback (innermost last):
File “/Users/spearl/SPIS_4_0_00_OSX/SpisUI/Bin/SpisNumCaller.py”, line 150, in selectionOkButton
File “/Users/spearl/SPIS_4_0_00_OSX/SpisUI/Bin/ProjectWriter2.py”, line 116, in createNewProject
File “/Users/spearl/SPIS_4_0_00_OSX/BinOSX/./…/SpisUI/BinOSX/…/…/ThirdPart/Jython/jython2.2/Lib/javapath.py”, line 105, in isdir
File “/Users/spearl/SPIS_4_0_00_OSX/BinOSX/./…/SpisUI/BinOSX/…/…/ThirdPart/Jython/jython2.2/Lib/javapath.py”, line 27, in _tostr
TypeError: isdir() argument must be a str or unicode object, not ‘NoneType’ object
Does anyone have any ideas on what I can do?
Thanks a lot,

Message by Gethyn Lewis:
Have you tried optimizing the tetrahedra in the gmsh tools?