[Archive] SPIS 4.0 for Linux 32bit/64bit

Message by abul anuar:
Hi, i spent the last couple of days trying to figure out why the final release SPIS doesn’t work on my machine. I figure out couple of things which i think need attention from the developer.

  1. the file runSpisxxx32bit.sh in the complete linux archive is not working. i look at the shell script and i think it is jumbled with 64bit command. Unable to load Cassandra/VTK library during startup because of the 64 bit issue when you run SPIS (SPIS is running but unable to display 3d results). Try to replace the shell script with the one in the RC2, but not working :). Now using RC2 instead of the final release.
b. I'm running Ubuntu 32 bit and unable to run GMSH 2.0.8. when i called the CADGeom, nothing happens. I tried to replace the gmsh with the latest version (2.4.2) and found that the latest version works. that's for now guys. thanks regards, abul

Message by julien:
We just saw this problem. This was due to a mistake in the packaging of scripts and the ThirPart. For this new release, we have defined a new production/packaging line, theoretically more robust, but apparently we still must reinforce some tests/checking. Thanks for your feedbacks and sorry for the inconvenience.
Your analysis and your comments are fully right. But to simplify the use, we are doing a repackaging of a pure and verified Linux 32bits version only in place of the corrupted 32/64bits one currently online.
Thanks again,
Julien for the SPIS team.

Message by julien:
This has been fixed in the Linux 32 bits version available at the following address SPIS_4_0_00_LINUX_X32.tgz.
Julien Forest.

Message by Ignacio Rocca:
Hi all, I downloaded the last Linux version ( SPIS_4_0_00_LINUX_X32.tgz ) and it doesn´t works with your own JAVA machine. I changed the script runSpis_JRE_&_32b.sh and now works with my JAVA machine of my Kubuntu.
For other hand, when I want to start CADTool, it doesn´t work like abul told on the first post. Someone saw those errors?
When the 64 bits stable version will be available?

Message by abul anuar:
I still unable to run the gmsh 2.0.8 provided with SPIS. I figured that it is missing some library. regards, abul.

Message by Ignacio Rocca:

Hi abul, did you check if another version of GMSH run under linux? I tried to fix the error but there are no new news!

Message by julien:
Hi all,
Two problems are outlined here:

  1. JVM: We reocmmand to use the embeded JVM (in ThirdPart). Most of the Linux systems use th OpenJDK by default and this one will not work with the JNI wrapping of VTK. You must use a SUN based JVAM (at least a version 1.6).
  2. After some testings, apparently the binary version of Gmsh provided on the Web site (and embeded in SPIS) is not fully 64bits. This is whyt the meshsing phase does not work properly on some Linux systems.
    Its works on my Suse only if I install in add of the 64 bits, the 32bits version of Fltk, Glu, glic… A recommend to recompile Gmsh for you own system if this one is full 64bits.
    Actually, contributions are welcome…
    Best,Julien Forest
    (Artenum’s crew)