[Archive] Problem loading geometry

Message by Amin Ghiasi:
Hi everybody,
When I want to load my geometry with “Load Geom” in SPIS, there is such an error: “Exception raised in taskCADImporter. Task aborted!”. Gmsh shows my geometry correctly and gives no error after opening it. I was wondering what is wrong with my geometry? I save my geometry in .step with Solidworks and then convert it to .geo using Gmsh. I run SPIS 4.3.1 in XP 32 bit Operation System in a Virtual Machine. I have also tried Fedora OS with no result.
Best regards,Amin

Message by Amin Ghiasi:
I solve my Problem :slight_smile:

Message by Amin Ghiasi:
I solved my problem :slight_smile:

Message by Benoit Thiebault:
This is great news.
If you could share the soution to the community, that would be very nice
Kind regards,

Message by Amin Ghiasi:
I changed the geo file manually. I mean I deleted all lines and circles and drew them again using Gmsh (points where still remained)!!! As far as I understand, there is a command named spline (in my geo file) which SPIS is not familiar with. By deleting all objects except points, I construct my geometry using familiar commands (point, line, circle). It took very long but there was no other ways for me!

Message by Amin Ghiasi:
In simple words, I constructed my geometry file again.
Sincerely Yours,