[Archive] Operating system for SPIS

Message by Guillaume Tcherniatinsky:
Since I use SPIS I experience a lot of instability problems while creating my models: often, then software freezes or crashes, and the weird thing is that even by tracking changes in the project at each step with git, I don’t see any recurrent scheme which leads to these problems. Even weirder, The project SphereLowResolution provided when you download SPIS works well at the simulation step but crashes in some cases when I reconstruct it, at meshing step.
As I can’t find a reason for this behaviour, except an error message indicating an OS incompatibility, I am trying to change my operating system in order to see if it is going to work better. I already tried Scientific Linux 6.7 and the last version of Ubuntu with a virtual machine, and both encounter the same problem.
My questions are:

  • If you have already runned SPIS under one of these OS, have you experienced the same kind of instabilities? If yes, how did you fix them?
  • If not, on which OS did you successfully or unsuccessfully run SPIS?
Thank you! Guillaume

Message by Guillaume Tcherniatinsky:
By the way, I already tried increasing java memory to 4 GO. I also tried to reinstall gmsh independently and adapt path.

Message by Guillaume Tcherniatinsky:
Thanks to Artenum team I have actually solved this issue. I will explain what it was here so that people encountering the same problem can have a clue about what to do with it!
My mistake was the way I was creating new projects using files in the old ones. When you create a new project and want to use a .geo from an existing project, you can do it from SPIS-UI (user interface) in the geometry editor by clicking “Open an existing geometry file” and by finding the file you want in your old project. However, it can be dangerous: sometimes, when you try to edit your imported geo file, the file actually edited is the one in the location from where you imported it. This is very annoying because you usually don’t want your old project to be corrupted while you are creating a new one (if you want to compare two refinements for example). The best way to solve that is actually to import your file, to save the project and to restart SPIS so that the edited file are the ones in the new project from now on. Furthermore, if you see that after restarting SPIS your geo file is back to its old version, your work isn’t necessarily lost even without a version control tool. Check in the old project if you haven’t edited the wrong file.
As I didn’t know that trick, I was copying geo files from one project to another by hand so that they could stay uncorrupted. It was the starting point of all my instabilities: there is a hidden finite-state machine in the software that is moved automatically when you import files from SPIS-UI, but that can’t update itself if you modify .spis5 folder by hand. You should never (or only if you know exactly what you are doing) modify what is inside .spis5 projects without using SPIS-UI for that reason.
I hope that explanation is clear and helped you. Don’t hesitate to ask if it isn’t, so that nobody else has to face that problem!

Message by Alexandru Cornogolub:
Well, I’m discovering the same problem. So you should import files and after this always restart SPIS…