[Archive] mesh dependency

Message by Benedek Prágai:
I have a problem with creating new projects, and I think it’s about the mesh. So I try to make project with the same geometry, but with different meshes. I change the mesh density only on one surface (I tried with multiple surface, and I got the same error), and above a certain density (to be exact under 0.1 meter characteristhic length) I got the following error when I hit “Finalize run configuration and save project”:
Ooops! There was an error while initializing the numerical kernel.
Please report it to the development team or on SPIS bug tracker.
Do not forget to include the debug.txt file at the root of the software.
java.lang.ArrayIndexOutOfBoundsException: -1
at spis.Solver.Poisson.PoissonInit.interpolatePotential(PoissonInit.java:1427)
at spis.Solver.Poisson.ConjGrad3DUnstructPoissonSolver.interpolatePotential(ConjGrad3DUnstructPoissonSolver.java:1076)
at spis.Surf.SurfInteract.DustySurfacesInteractor.computeForce(DustySurfacesInteractor.java:642)
at spis.Surf.SurfInteract.DustySurfacesInteractor.computeSample(DustySurfacesInteractor.java:614)
at spis.Surf.SurfInteract.DustySurfacesInteractor.computeInteraction(DustySurfacesInteractor.java:550)
at spis.Top.SC.InteractSC.computeInteraction(InteractSC.java:191)
at spis.Top.SC.InteractSC.computeInteraction(InteractSC.java:202)
at spis.Top.Simulation.SimulationFromUIParams.init(SimulationFromUIParams.java:671)
at spis.Top.Simulation.SimulationFromUIParams.(SimulationFromUIParams.java:451)
at spis.Top.Top.NumTopFromUI.(NumTopFromUI.java:158)
at org.spis.ui.spis.num.numerical.core.implementation.NumericalCore.(NumericalCore.java:95)
at org.spis.ui.ui2num.util.Ui2Num.buildNumTopFromUI(Ui2Num.java:401)
at org.spis.ui.ui2num.command.NumTopFromUICommand.run(NumTopFromUICommand.java:164)
at org.spis.ui.ui2num.command.NumTopFromUICommand.run(NumTopFromUICommand.java:53)
at org.keridwen.core.messaging.AbstractCommand.execute(AbstractCommand.java:208)
at org.keridwen.core.messaging.DefaultBundleController$CallableCommand.call(DefaultBundleController.java:260)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)
If I increase one characteristic length and decrease the other to keep the mesh element number on the same level, I still get the error.
Can you help me what can cause this problem?
OS: Ubuntu, Spis: Spis-Dust 5.2.4, gmsh: 3.0.6 (I tried gmsh 2 too)
Thank you for helping me,
Benedek Prágai

Message by Aldo:

  1. once encountered this kind of errors when my geometry was "too close" to the borders, so a "large" mesh would deform nearby the boundaries of the experiment.
It got better once I made the computational volume larger or the mesh less coarse.Kind of "try and error". Hope it helps.