[Archive] Inactive or defective viewers within UI window?

Message by Marinus Krommenhoek:
Hi, I’m using Windows 7
While going through the example simulations I have found that I cannot interact with the viewers while in the UI main window (I can only sort of rotate the geometry or mesh but can’t zoom in and out and what I see is a super zoomed in version of a shape or surface) but can once I run the required programs, like Gmsh. I would just like to know whether this should be the case, also a rendering error is generated and then displayed on the vtkOutputWindow (referring to openGL for a win32 system) whenever I try to move from the group tree to the mesh section while this window is active I cannot “rotate” the shape in the group section (this freezing tends to happen sporadically once the window closes).
That said I have noticed that once I run Cassandra I can’t find any files for it to open in any of the data folder’s sub-folders even once I’ve run the example simulations. All things considered though the examples all simulated fine except for crashes associated with the group editor or the Newton’s inability to converge.
Does any one have advice?

Message by Marinus Krommenhoek:
I forgot to say that I’m using a 64 bit system and the SPISGEO for it.

Message by Benoit Thiebault:
Dear Marinus,
To see your 3D model fully, you can:

  • Click on the 3D window to get the focus and then type the letter "R" (as resize) on your keyboard.
  • When you click the 3D window with the right button of the mouse, you can zoom in and out by dragging the mouse towards or backwards the scene
  • With the left click + another key pressed (I don't remember if it is the "shift", the "control" or the "alt" key on windows), you can also zoom in and out
We have also noticed some sporadic instabilities of VTK on Windows 7 leading to the vtkOutputWindow being displayed. When these window is displayed, it sometimes leads to freeze the 3D view. If the 3D views are not critical for you (when you know your geometry well for instance), you can also use the SpisGeoNo3D.bat script to launch SPIS in degraded mode. This is not ideal but can help sometimes. Regarding output files, when you have run a simulation, they are saved as NetCDF files in the project folder: MyProject/MyStudy/Simulations/Run1/OutputFolder. These files cannot be visualized directly with the 3D viewer, you have to export them in the VTK format. To do so, in the data miner screen (the one just after the simulation screen), you can select one (or more by holding the "control" or the "shift" keys) result file and click on the "Export" button to save the output files as VTK files at the desired location. You can also directly visualize them in SPIS by selecting them and clicking the visualize button. I think some of these tips are also written in the user manual. Hope this helps, Benoît

Message by Marinus Krommenhoek:
Thanks for that it definitely helped,
Admittedly I forgot about the bit on conversion to VTK unstructured data sets and their exporting to Cassandra to get the desired results in the manual. However I did try what you recommended for interaction with the viewers, basically your first and second recommendations work as long as it doesn’t freeze (naturally) but for the third (as tried before) “shift”+left mouse button tends to move the shape around and the other two combinations allow you to rotate the shape faster than when not pressing them in.
Oh, and the Newton not converging was just a local parameter I messed up when I was playing with the group tree.