[Archive] Error when changing material property

Message by Millan Diaz-Aguado:
when I change material property on the SphereLowResolution example it crashes.
SPIS 5.1.2
Ooops! There was an error while initializing the numerical kernel.
Please report it to the development team or on SPIS bug tracker.
Do not forget to include the debug.txt file at the root of the software.
java.lang.ArrayIndexOutOfBoundsException: 63
at spis.Surf.SurfInteract.BasicMaterialModel.computeConductivity(BasicMaterialModel.java:385)
at spis.Top.SC.RCCabsSC.deriveCoatingConduct(RCCabsSC.java:1120)
at spis.Top.SC.RCCabsSC.deriveMatrixes(RCCabsSC.java:774)
at spis.Top.SC.RCCabsSC.deriveCircuitAndMap(RCCabsSC.java:756)
at spis.Top.SC.RLCSC.deriveCircuitAndMap(RLCSC.java:189)
at spis.Top.SC.RCCabsSC.deriveCircuitAndMap(RCCabsSC.java:1029)
at spis.Top.SC.RCCabsSC.init(RCCabsSC.java:283)
at spis.Top.SC.RCCabsSC.(RCCabsSC.java:272)
at spis.Top.SC.RLCSC.(RLCSC.java:149)
at spis.Top.Simulation.SimulationFromUIParams.init(SimulationFromUIParams.java:1078)
at spis.Top.Simulation.SimulationFromUIParams.(SimulationFromUIParams.java:438)
at spis.Top.Top.NumTopFromUI.(NumTopFromUI.java:111)
at org.spis.ui.ui2num.util.Ui2Num.buildNumTopFromUI(Ui2Num.java:351)
at org.spis.ui.ui2num.command.NumTopFromUICommand.run(NumTopFromUICommand.java:162)
at org.spis.ui.ui2num.command.NumTopFromUICommand.run(NumTopFromUICommand.java:52)
at org.keridwen.core.messaging.AbstractCommand.execute(AbstractCommand.java:200)
at org.keridwen.core.messaging.DefaultBundleController$CallableCommand.call(DefaultBundleController.java:259)
at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

Message by Benoit Thiebault:
What did you change in the material properties?
Did you just modify a value or did you add a new characteristic?

Message by Millan Diaz-Aguado:
I changed it in the FaceGroup - 56, in the Groups/Properties editor, the S/C material tab from CERS to gold. I’m just modifying the SphereLowResolution.spis5
Thank you,

Message by Christian Imhof:
Hi Millan,
a quick question from my side: Have you tested this also in the previous version of SPIS (V 5.1.0)?
I am asking because I have also tried to set up some simulations in the latest version 5.1.2 after it has been released and I get the same error message every time I want to perform a simulation (also the same model has worked properly in the 5.1.0 versio of the tool). So, it is possible that there is a maybe a principle problem or bug in the new release.

Message by Benoit Thiebault:
Dear all,
First, I would like to thank you for your feedback. Thanks to this community effort, we have found a critical bug in SPIS 5.1.2 that broke the handling of material properties. As announced on the download page, we are working on the issue and will release a patch as soon as possible. In the meantime, we advise to use the previous version of SPIS: version 5.1.0.
Sorry for the inconvenience.
Kind regards,

Message by Benoit Thiebault:
Dear all,
SPIS 5.1.4 is out. It should solve your problem. Please do not hesitate to post on the forum if you see new bugs.