[Archive] CADImporter Task doesn't complete

Message by David Parrott:
I’ve just finished putting together a model in Gmsh which is quite a bit larger and more complex than anything I’ve tried in SPIS to date, with 700 points, 1000 lines and 400 surfaces (but just 1 volume). It meshes in Gmsh, no problem.
Unfortunately, when I come to hit “Load Geom” in SPIS, the task gets as far as “Parsing … DONE”, then becomes stuck. There’s nothing in the Jython Log to indicate a problem (aside from complaining about the subloops!).
All physicals have been defined. I’ve tried loading the model as a set of files with one master, and also as a single unrolled .geo file, with identical results.
Does anyone have the missing piece to the puzzle?
P.S. Upgrading to Gmsh 2.0.8 for your model creation is highly recommended (\http://www.geuz.org). The improved stability when manipulating views of 2D meshes has saved me many aspirins.

Message by wang ji:
“All quads” meshing function has been removed in GMSH 2.0.* series, does it influence the meshing and importing processes?In PIC algorithm, the most convinient element is the square and cube, how does SPIS deal with tetrahedron in PIC calculation?

Message by David Parrott:
Ok, the geometry file does load, but takes 30 mins to do so, which I wasn’t prepared for. As regards using GMSH 2.0*, two obstacles immediately arise. Firstly, the model cannot be meshed in GMSH 1.65, so a mesh file must be created independantly from SPIS 3.6 and manually imported. Secondly, the GMSH .msh file format has been altered for GMSH 2.0, making some simple file conversion necessary before SPIS will accept it.
So far so good … except that an exception is now raised when I try to convert the GEOM/CAD groups into mesh groups:
Conversion of group 6

Exception raised in task
Traceback (most recent call last):
File “C:\spis3_6\ThirdPart\Jython\jython-2.1…\SpisUI\Bin\Tasks\TaskConvertGroup.py”, line 92, in run_task
myBoss.ConvertGeoToMeshGroup( sharedGroups! ‘GeoGroupList’ !, shared! ‘MeshGroupList’ !, shared! ‘Mesh’ !)
File “C:\spis3.6\ThirdPart\Jython\jython-2.1…\SpisUI\Bin\GroupManager.py”, line 162, in ConvertGeoToMeshGroup
MeshGroupTmp.jMeshGroup = mesh.getMeshGroupById(GeoGroup.Id)
java.lang.ArrayIndexOutOfBoundsException: java.lang.ArrayIndexOutOfBoundsException: -1

I’m not sure what to make of this, perhaps some inconsistency between the geometric model and the mesh?

Message by David Parrott:
Problem solved. The exception arose because my imported mesh file did not include the physical point and line groups that SPIS adds when importing a Gmsh geometry file. The solution was to mesh the “tmp.geo” file that SPIS places in the temporary workspace after an import.

Message by julien:
As you outline such problem may actually have various reasons:

  • First the format of the CAD file has changed with Gmsh 2.0.8 and SPIS 3.6 did not support it perfectly. This is fixed in a new version of SPIS (3.7 RC 09) available as realese candidate at the following address. The "tmp.geo" file is actually a temporary file generated by SPIS after a first import of the initial CAD files (i.o Load Geom icone). This file contains some elements re-ordering. I recommand to use the new version of SPIS.
  • Sometimes, on very slow computer, the thread can lead to a dead-lock and generate punctually such type of error. Just re-run the task in this case.
  • In case of specific installation, a wrong path toward the Gmsh application.
Best, Julien. For the Artenum team.